View Single Post
Old 06-09-2010, 03:51 PM   #4
trbotyz
4CFEDTA
 
trbotyz's Avatar
 
Join Date: Feb 2009
Location: Monterey
Posts: 68
Rep Power: 10
trbotyz is on a distinguished road
Default

Quote:
Originally Posted by MidnightToker View Post
Check the oil filter that you took off if you still have it and make sure that the O ring gasket is still on it. Sometime what happens is they stick to the block and then cause a leak. That would be my guess anyway if the oil change was the only thing that you have done/changed.
I already checked and that was not the problem unfortunately. I was hoping it was going to be a simple, stupid mistake I made, but I checked the filter, drain plug, and oil cap first, and they all seemed to be on tight.

Quote:
Originally Posted by AcE View Post
That happened to me once. I guess I did not tighten the oil all the way or sum shiet and I turned on the car to take it down from ramps and when I get off I look under the car and see a puddle of oil. I raged hard at that point. The filter seemed fine to me but I took it off again and put it back on and added another 5.5 querts of synthetic and it was fine after that.
I took everything back off and drained all of the oil out again. I am planning to get some brake cleaner and clean up underneath the car (covered in oil from around the oil pan on back), fill it up with oil, jack it up, and start it to see if I can see any leaks underneath. I won't have time to devote to it until this weekend though. Thanks for the input guys.
trbotyz is offline   Reply With Quote